Conflictos con libdbusmenu-glib al actualizar Manjaro

Hoy en la mañana me dispuse a actualizar Manjaro como es costumbre y me encuentro con unos problemas, concretamente son unos archivos en conflicto con **libdbusmenu-glib**

error: error al realizar la transacción (archivos en conflicto)
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/client.h existe en el sistema de archivos
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/dbusmenu-glib.h existe en el sistema de archivos
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/enum-types.h existe en el sistema de archivos
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/menuitem-proxy.h existe en el sistema de archivos
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/menuitem.h existe en el sistema de archivos
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/server.h existe en el sistema de archivos
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/types.h existe en el sistema de archivos
libdbusmenu-glib: /usr/lib/girepository-1.0/Dbusmenu-0.4.typelib existe en el sistema de archivos
libdbusmenu-glib: /usr/lib/libdbusmenu-glib.so existe en el sistema de archivos
libdbusmenu-glib: /usr/lib/libdbusmenu-glib.so.4 existe en el sistema de archivos
libdbusmenu-glib: /usr/lib/libdbusmenu-glib.so.4.0.12 existe en el sistema de archivos
libdbusmenu-glib: /usr/lib/pkgconfig/dbusmenu-glib-0.4.pc existe en el sistema de archivos
libdbusmenu-glib: /usr/share/gir-1.0/Dbusmenu-0.4.gir existe en el sistema de archivos
libdbusmenu-glib: /usr/share/vala/vapi/Dbusmenu-0.4.vapi existe en el sistema de archivos
Ocurrieron errores, no se actualizaron paquetes

Mensaje completo de la actualización:

#Quitar Plank
En otras ocasiones he resuelto los problemas desinstalando el paquete conflictivo, actualizando y volviendo a instalar, en este caso en particular los paquetes **libdbusmenu** son requeridos únicamente por [plank](https://launchpad.net/plank) un dock sencillito que me gusta mucho como se ve en el escritorio. Así que ni modo, lo primero que hay que hacer es desinstalar Plank.

sudo pacman -R plank
sudo pacman -R libdbusmenu-gtk3
sudo pacman -R libdbusmenu

# Actualizar el sistema
Hecho lo anterior, la actualización ocurre sin problemas…

sudo pacman -Syyu

actualización de manjaro ya sin conflictos
actualización sin conflictos.

# Reinstalar Plank
Para reinstalar Plank solo tuve que hacerlo con yaourt.

yaourt plank

reinstalando plank
reinstalando plank

Y listo !!! 🙂

* [System cannot update](http://forum.manjaro.org/index.php?topic=8095.msg71549#msg71549)

5 thoughts on “Conflictos con libdbusmenu-glib al actualizar Manjaro

  1. muchas gracias, por dos cosas:
    -La solución al problema de las librerias y la actualización
    -Gracias a que desinstale plank descubrí synapse, que nunca lo había utilizado(a pesar de estar a solo un super+s de distancia) y ahora estoy completamente enamoradx de él; por la rapidez y lo minimalista del diseño pero también por la elegancia de correr todas tus aplicaciones con un nombre aproximado, al hacerlo enfrente de la gente se quedan así: O_O”!!!! como yo me he quedado desde hace poco que lo uso. Estaba pensando considerablemente en pasarme a Mac por el tema de la batería y la interfaz, pero con esto definitivamente por la interfaz: linux. Ahora solo me queda encontrarme una laptop con bateria que dure 7-9 hrs XDDDDD

    • También tengo Synapse, antes tenía una mejor integración con Zeitgeist y era la onda, no sólo arrancaba los programas, también tenía a la mano mis archivos más utilizados.

      A veces ofrecen baterías para laptops con un mayor número de celdas 🙂 eso puede ayudar.

¡Me encantaría saber que opinas!

%d bloggers like this: