Haroopad, otro editor con soporte para Markdown

Haroopad es otro editor de textos con soporte para Markdown. Últimamente esta herramienta que sirve para generar documentos en formato HTML esta ganando mucha popularidad. No hace mucho se anunció que WordPress incluye soporte para Markdown. El nuevo sistema de blogging Ghost lo anuncia como una de sus características principales. GitHub lo utiliza en su sistema de documentación y comentarios y yo lo utilizo desde hace tiempo para generar los artículos de este blog.

Haroopad, otro editor con soporte para Markdown

Lo bueno

Haroopad es un proyecto que comienza, pero lo hace con el pie derecho. Esta repleto de cosas buenas, por ejemplo dispone de un panel simultáneo para ver el texto generado mientras se escribe. Tienen un sistema de autocompletado para las etiquetas que usa Markdown, una interfaz amigable repleta de temas y una comunidad que hará que el proyecto crezca.

Tiene varios detalles que hacen cómodo usarlo.

Cosas que le faltan

Como es un trabajo en desarrollo todavía carece de muchas cosas, por ejemplo los menús ¡No tiene atajos de teclado!, aunque si lo prefieren, pueden activar el modo VIM que hará que usen menos el mouse, pero tuve algunos problemas con Haroopad al activarlo.

Tampoco tiene un corrector ortográfico que se extraña y algunas opciones aún no están disponibles, como la opción de exportar a PDF o una integración con wordpress.

Para instalarlo en Manjaro

Haroopad funciona bien en Windows, Linux y MacOsx. Para instalarlo en Manjaro tuve algunos problemas, esta disponible en yaourt pero hay que hacer algunos ajustes en el archivo PKGBUILD para lograr que se instalé. Si intentan:

yaourt -S haroopad

Probablemente les muestre un mensaje de error como este…

error: error al realizar la transacción (archivos en conflicto)
libudev.so.0: /usr/lib/libudev.so.0 existe en el sistema de archivos
Ocurrieron errores, no se actualizaron paquetes

Tuve que hacer una consulta a los foros de Manjaro para solicitar algo de ayuda que llegó inmediatamente: Topic: Problem installing Haroopad y me entregaron un nuevo archivo PKGBUILD que omite la necesidad de algunas dependencias.

Conclusiones

Es un buen programa, de eso no hay duda y cuando concrete muchas de las opciones que están pendientes será un excelente compañero de todos aquellos que generamos contenido usando Markdown.

10 thoughts on “Haroopad, otro editor con soporte para Markdown

    • Pues es que depende de tus gustos, por ejemplo Uberwriter funciona muy bien para escribir sin distracciones. ReText no es muy bonito, pero tiene buenas herramientas de exportación. Springseed se puede sincronizar a tu cuenta de dropbox y este último, que tiene cosas que prometen, pero todavía esta un poco verde. El que más te guste 🙂

  1. hey viejo he estado intentando instalarlo en manjarobox pero no me deja, he editado el archivo pkgbuild pero nada, sigue el error, me he descargado el pkgbuild desde aur sigue igual, lo he cambiado por el archivo que dices, todavia nada, no se cual sea el problema.

  2. este es el error que tengo.

    [master@manjaro-master ~]$ packer -S haroopad

    Aur Targets (1): haroopad

    Proceed with installation? [Y/n] y Edit haroopad PKGBUILD with $EDITOR? [Y/n] n Edit haroopad.install with $EDITOR? [Y/n] n ==> Making package: haroopad 0.10.0-2 (Fri Jan 3 18:31:47 AST 2014) ==> Checking runtime dependencies… ==> Checking buildtime dependencies… ==> Retrieving sources… -> Downloading haroopad-v0.10.0-i386.deb… % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 534 0 534 0 0 676 0 –:–:– –:–:– –:–:– 675 100 33.5M 100 33.5M 0 0 57575 0 0:10:11 0:10:11 –:–:– 45421 -> Found Haroopad.desktop -> Found x-markdown.xml ==> Validating source files with md5sums… haroopad-v0.10.0-i386.deb … FAILED Haroopad.desktop … Passed x-markdown.xml … Passed ==> ERROR: One or more files did not pass the validity check! The build failed.

    y el topo es el paquete .deb!

  3. bueno para empezar veo que usas packer en lugar de yaourt, segundo veo un problema de validación que es muy diferente al que me ocurre a mi (un problemilla con las dependencias).

    ¿Porque no intentas con yaourt?

  4. jejejejee primero lo hice con yaourt me da el mismo error, tambien con pacman, perdona por no decirlo antes pero en republica dominicana los apagones son cosa de cada momento por eso puedes alguna vez encontrar que escribo mal oh repito palabras, la presion es increible.

  5. mmmm , si tienes tantos apagones, a lo mejor el archivo que descargaste esta corrompido.

    ¿Podría ser, no crees?

    Podrías intentar borrar el caché de paquetes descargados, aunque no estoy seguro si también lo usa yaourt

    pacman -Scc
    

    O buscar en la carpeta temporal de yaourt

    /tmp 
    

    pero supongo que esta carpeta se borra después de cada arranque.

    Por que creo que lo que pasa es que no se descarga correctamente el archivo y por eso no pasa la verificación.

  6. uuuum si puede ser, porque al descargarme el pkgbuild y ejecutar makepkg -s me dice que el haroopad.deb no se termino de descargar.

¡Me encantaría saber que opinas!

%d bloggers like this: