Wicd en ubuntu con lxde

Tengo una laptop con ya sus buenos megabytes recorridos. Tiene sus años pero todavía funciona de manera aceptable. Le instalé Ubuntu 11.04, pero para ser sinceros se pone rejega para ejecutar Gnome y por eso le instalé LXDE. Hasta aquí todo bien.

El problema es que si instalo LXDE no incluye un manejador de conexiones de redes inalámbricas y no me puedo conectar mediante la tarjeta wifi, solo con la tarjeta ethernet.

Sabía del programa Wicd, es muy útil porque no tiene dependencias gráficas así que funciona bien en Gnome, KDE, Lxde, Fluxbox y lo que le pongas.

Para instalarlo fue suficiente con un:

sudo apt-get install wicd
Wicd Network Manager
Wicd Network Manager

Y todo debería de ser perfecto, si no fuera porque al intentar conectarme a una red con cifrado WPA2 me marca que no pudo validar la contraseña. Le moví a varias opciones del programa sin mucho éxito. Después de investigar un rato en internet la solución que funcionó fue…. pausa dramática .. detener el servicio Network Manager con:

sudo service network-manager stop

Después de hacer eso el problema desaparece.

Claro que esto no ocurre en instalaciones que son específicamente con lxde, como lubuntu o linux mint lxde.

Configurar la tarjeta GMA500 para dos monitores

Tengo una pequeña notebook Acer Aspire One AO751h y recientemente conseguí otro monitor para usar mi equipo más cómodamente en casa.

El problema es que al conectarlo no funcionó, probé presionando las teclas **Fn + F5** sin ningún resultado.

Para evitar malos entendidos mi configuración es la siguiente:

* Equipo Acer Aspire One AO751h con tarjeta gráfica GMA500
* Driver EMGD instalado siguiendo estas indicaciones [Acer Aspire One AO751h con Linux Mint 11 LXDE](http://linuxman.blogsome.com/2011/11/15/acer-aspire-one-ao751h-con-linux-mint-11-lxde/).
* Linux Mint 11 LXDE.

LXDE tiene un comando para revisar la configuración de los monitores llamado **lxrandr** pero solo me muestra la configuración de un solo monitor.

lxrandr - Mostrar ajustes

Supuse que tenía que modificar el archivo **xorg.conf** , y después de investigar un poco en google probé modificando este archivo:

sudo gedit /usr/share/X11/xorg.conf.d/10-emgd.conf

Y lo reemplacé con esta información, pero por favor, hagan un respaldo primero del archivo solo por precaución.

## 10-emgd.conf

Section "Module"
    Load "dbe"
    Load "dri"
    Load "dri2"
    Load "record"
    Load "extmod"
    Load "glx"
EndSection

Section "Monitor"
    Identifier   "MainMonitor"
    ModelName    "LCD Panel 1366×768"
EndSection

Section "Screen"
    Identifier    "MainScreen"
    Device        "MainDevice"
    Monitor       "MainMonitor"
    SubSection "Display"
    Depth     24
    Modes    "1366×768"
    EndSubSection
EndSection

Section "Device"
    Identifier "MainDevice"
    Driver     "emgd"
#    Driver "vesa"
    VendorName "Intel(R) DEG"
    BoardName  "Embedded Graphics"
    BusID      "0:2:0"
    Screen      0
    VideoRam    32768
    Option     "PcfVersion"             "1792"
    Option     "ConfigId"               "1"
    Option     "ALL/1/name"             "lvds-display"
    Option     "ALL/1/General/PortOrder"        "24000"
    Option     "ALL/1/General/VideoRam"                 "32768"
    Option     "ALL/1/General/DisplayConfig"        "2"
    Option     "ALL/1/General/DisplayDetect"        "1"
    Option     "ALL/1/General/Accel"            "1"
    Option     "ALL/1/General/DRI"          "1"
    Option     "ALL/1/General/DRI2"         "1"
    Option     "ALL/1/General/XVideo"           "1"
    Option     "ALL/1/General/XVideoBlend"      "0"
    Option     "ALL/1/General/TearFB"           "0"
    Option     "ALL/1/General/ShadowFB"         "0"
    Option     "ALL/1/General/SWCursor"         "0"
    Option     "ALL/1/Port/4/General/name"      "LVDS"
#    Option     "ALL/1/Port/4/General/Rotation"     "0"
    Option     "ALL/1/Port/4/General/Edid"      "1"
#    Option     "ALL/1/Port/4/Attr/70"          "100"
#    Option     "ALL/1/Port/4/Attr/71"                   "20300"
    Option     "ALL/1/Port/4/Attr/72"           "0"
#    Option     "ALL/1/Port/4/FPInfo/BkltMethod"         "1"
#    Option     "ALL/1/Port/4/FPInfo/BkltEnable"         "1"
    Option      "ALL/1/Port/2/General/name"     "SVDO"
    Option  "ALL/1/Port/2/General/Edid"     "1"
    Option  "ALL/1/Port/2/General/EdidAvail"    "1"
    Option  "ALL/1/Port/2/General/EdidNotAvail"     "7"
EndSection

# Secondary (for dual-head only) display
Section "Monitor"
    Identifier   "VGAMonitor"
    ModelName    "VGA Output"
EndSection

Section "Screen"
    Identifier    "VGAScreen"
    Device        "VGADevice"
    Monitor       "VGAMonitor"
    SubSection    "Display"
    Depth   24
    Modes   "1600×900"
    EndSubSection
EndSection

Section "Device"
    Identifier "VGADevice"
    Driver     "emgd"
    VendorName "Intel(R) DEG"
    BoardName  "Embedded Graphics"
    BusID      "0:2:0"
    Screen     1
EndSection

Section "ServerLayout"
    Identifier     "Dual Head Layout"
    Screen  "MainScreen"
    Screen  "VGAScreen" RightOf "MainScreen"
EndSection

Section "DRI"
        Mode         0666
EndSection

Section "ServerFlags"
#   Option "AutoAddDevices" "false"
EndSection

Estos son los resultados…

2 monitores, el lcd y uno externo

Creo que todavía se puede mejorar un poco la configuración, les mantendré al tanto de las modificaciones.

### Actualización : Mostrar solo el monitor externo.
Para mostrar solamente el monitor externo cambiamos el valor de **DisplayConfig** a **1** de la siguiente forma:

Option     "ALL/1/General/DisplayConfig"        "1"